Dockerで“npm install”後に“Husky requires Git >=2.13.0. Got v2.11.0.”が表示された時の対処方法

Created:
Updated:

npm install後にエラーが発生

docker-compose exec {コンテナ名} npm install

dockerでnpm installを実行すると、下記エラーが発生しました。

> husky@4.3.8 install /node_modules/netlify-cli/node_modules/husky
> node husky install

husky > Setting up git hooks
Husky requires Git >=2.13.0. Got v2.11.0.
husky > Failed to install

対処方法はnodeのバージョンアップデート

Node - Official Image | Docker Hub

利用しているnodeのdocker imageのバージョンが低い可能性があるため、アップデートをすると解消する可能性があります。

# docker-compose.yml
services:
  app:
    image: node:1x.x.x
    ↓
    image: node:17.x.x

一緒に読みたい本

TOP